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— System Requirements @

+0S a
= Windows XP (32-bit) or Vista (32- or 64-bit)
= Mac OS X 10.4.8 or later (x86 only)
= Linux (tested on Linux Ubuntu Hardy Heron)

% Supported Development Environments

= Eclipse 3.4 (Ganymede) or 3.5 (Galileo)
* http://www.eclipse.org/downloads/
« Eclipse JDT plugin (included in most Eclipse IDE packages)

= JDK 5 or JDK 6 (JRE alone is not sufficient)
= Android Development Tools plugin
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http://www.eclipse.org/downloads/

— Download and install Eclipse (_ﬁ;

“*Installing Eclipse "
" http://www.eclipse.org/downloads/

= Recommended Eclipse IDE packages: Eclipse IDE for Java EE
Developers, Eclipse IDE for Java Developers, Eclipse for
RCP/Plug-in Developers, or Eclipse Classic (3.5.1+)

Database Lab _



http://www.eclipse.org/downloads/

— Install Java @

+ Install Java
= Install Java to run Eclipse (In Ubuntu)

joo@ubuntu:~5 sudo apt-get install sun-java6-bin|

[sudo] password for joo:

Reading package lists... Done

Building dependency tree

Reading state information... Done

The following packages were automatically installed and are no longer required:
linux-headers-2.6.31-14 linux-headers-2.6.31-14-generic

Use 'apt-get autoremove' to remove them.

The following extra packages will be installed:
gsfonts-x11 java-common odbcinstldebianl sun-java6-jre unixodbc

Suggested packages:
equivs sun-java6-plugin 1a32-sun-java6-plugin sun-java6-fonts
ttf-kochi-gothic ttf-sazanami-gothic ttf-kochi-mincho ttf-sazanami-mincho
ttf-arphic-uming libmyodbc odbc-postgresql libctl

The following NEW packages will be installed:
gsfonts-x11 java-common odbcinstldebianl sun-java6-bin sun-java6-jre
unixodbc

= Install Java to run Eclipse (In Windows)

http://java.sun.com/javase/downloads/widget/jdk.jsp
JDK 5 or JDK 6 is recommended

To specify a JVM using configuration file, insert below contents to a text file

named eclipse.ini in the same folder as eclipse.exe

113

—vm
C:\Program Files\Java\jdk1.6.0 18\bin\javaw.exe”
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— Android SDK(1/2) 3

<+ Download and Install Android SDK

= Select a starter package
 http://developer.android.com/sdk/index.html

Download the Android SDK

December 2009

show mare

Windows android-sdk r04-windows zip 23069119 bytes c48b407de852bad83869f17337290997

Mac OS X (intel) android-sdk r04-mac 86.zip 19657927 bytes b08512765aa9b0369bb3bsfecdfiB3e3

Linux (1386) android-sdk_r04-linux 86.tgz 15984887 bytes ef4b06fd9dad4fdcdaei7o64fedeaee

The Android SDK has changed! If you've worked with the Android SDK before, you will notice several important differences:

If vou are new to the Android SDK, please read the Quick Start, below, for an overview of how to install and set up the SDK.
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— Android SDK(2/2)

= To install the SDK, simply unpack the starter packa
location and then add the location to your PATH
* In Ubuntu
IPATH=/android/android-sdk/tools: $PATH
* In Windows
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— Install the ADT(1/2)®)

< Install the ADT Plugin for Eclipse -,

~—

= For developing in Eclipse, set up a remote update

http://developer.android.com/sdk/eclipse-adt.html

% Installing the ADT Plugin

Eclipse 3.5 (Galileo)

1. Start Eclipse, then select Help = Install New Software.
2. In the Available Software dialog, click Add....

3. In the Add Site dialog that appears, enter a name for the remote site (for example,
"Android Plugin”) in the "Name" field.

In the "Location” field, enter this URL:

https://dl-ssl.g00ale. comfandroidfec| ipses

Mote: If you have trouble acquiring the plugin, you can try using "http" in the URL,
instead of "https" (https is preferred for securnty reasons).

Click OK.

4. Back in the Available Software view. you should now see "Developer Tools" added to
the list. Select the checkbox next to Developer Tools, which will automatically select
the nested tools Android DDMS and Android Development Tools. Click Next.

5. In the resulting Install Details dialog, the Android DDMS and Android Development
Tools features are listed. Click Next to read and accept the license agreement and
install any dependencies, then click Finish.

6. Restart Eclipse.

site and install the Android Development Tools(ADT)
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F.

— Install the ADT(2/2)®)

-

% Modify Eclipse preferences to point to the Androi
SDK directory

= Select Window > Preferences... to open the Preferences panel (Mac
OS X: Eclipse > Preferences)

= Select Android from the left panel.

= For the SDK Location in the main panel, click Browse... and locate your
downloaded SDK directory.

= Click Apply, then OK.

% If you have encountered any Problems, then
= Reference to http://developer.android.com/sdk/eclipse-adt.html
= Call teaching assistant
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— Adding SDK Components (3\5

% Installing SDK Components n
= you can select Window >Android SDK and AVD Manag

% you can quickly install set of development to
documentation

1. Select Available Components in the left panel. This will reveal all components
currently available for download.

2. Select the components you'd like to install and click Install Selected.
3. Verlfy and accept the components you want and click Install Accepted.

Android SDK and AVD Manager [x]

Virtual Devices

-

Sites, Packages and Archives

Installed Packages = [] & https://dl-ssl.google.com/androidjrepository/repository.xml
b Documentation for Android SDK, API 7, revision 1

b # SDK Platform Android 2.1, APl 7, revision 1

B ‘& Google APIs by Google Inc., Android API 7, revision 1

b # SDK Platform Android 2.0.1, API 6, revision 1

B ‘& Google APIs by Google Inc., Android API 6, revision 1

b

b

[

7 SDK Platform Android 2.0, API 5, revision 1
‘& Google APIs by Google Inc., Android API 5, revision 1

[F = snk Platfarm Andraid 1 /& APL A resviginn 2 :I
[+ [l
-Description
Android SDK Platform 1.5_r3
Revision 3
Add Site... | Delete Site... Display updates only Refresh| Install Selectedl
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— Get the latest Documentation ('ﬁi

% Development documentation
= |f you develop while offline

documentation package.

from the Eclipse IDE
= When you are online

Developers site.

« Use the Android SDK and AVD Manager to download the latest
« The documentation covers all versions of the API and lets you filter

out those versions that your application won't support
* Once installed, the documentation is also available to you directly

* you can always access the latest documentation at the Android
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— Download other SDK components ('ﬁ;

 Download other SDK components
= You can use the Android SDK and AVD Manager to download
other SDK components (ex. SDK Add-on)

= An SDK add-on provides a development environment for an Android
external library or a customized Android system image

= For example, the Google APIs Add-On lets you develop an application
that takes advantage of the Google Maps external library.
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___ Get started with an application

®

project

-

< Application project

= Once you've set up your SDK, the next step is to start a new application

project or move existing applications into the new SDK

= you can use the Hello World tutorial to get started quickly

<+ "Welcome to Android World”
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% In

— Hello World Tutorial(1/7)(%)

++ Create an AVD

Before you can launch the emulator, you must create an An
Device (AVD)

An AVD defines the system image and device settings used by the
emulator.

Linux
To create an AVD, use the "android" tool provided in the Android SDK

|jnn@ubuntu:~$ android create avd --name my avd --target }'I

The tool now asks if you would like to create a custom hardware profile.
For the time being, press Return to skip it ("no" is the default response)

In the above command, the --target option is required and specifies the
deployment target to run on the emulator

The --name option is also required and defines the name for the new
AVD
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— Hello World Tutorial(2/7)@

% Create an AVD(In Windows)
= Select Windows > Android SDK and AVD Manager

§ Android SDK and AYD Manager 1.} Create new AVD
nstalled Packages List of existing Android Yirual Devices: ( :
Awvailable Packages AVD Mame Target Name Platform APl Level News, ., MName: | Al’ldrﬂld_z. 1 |
= Mo AYD available = =
— Target: |.f-‘mc|rnic| 21 - &P Level 7 v|
epal...
. 50 Card:
Details,,,
e ® Size: | |[MIB v |
OFile: | | | Browse,.,,
@ Built-in: | Default (HYGA) |
(O Resolution: | | | |
Fiefresh
« A valid Android Yirtual Device, Hardware:
X An Android Virtual Device that falled to load, Click ‘Details’ to see the error, PI'CIDEI’W Value NEW, B

Abstracted LCD density 160

Delete

Force create

!CreateAVD [ Cancel ]
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— Hello World Tutorial(3/7)®

-

% Create a New Android Project

= After you've created an AVD, the next step is to start a new
project in Eclipse.

1. From Eclipse, select File > New > Project.

2. Select "Android Project” and click Next.

Select a wizard <>

r ‘l‘

—

Wizards:

|:'y'pe filter text |

P = General

= (= Android
J5 Android Test Project

P (= CVS

b = ]ava

P (= Examples

@ < Back Next > J | Cancel Finish
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— Hello World Tutorial(4/7)(®)

% Create a New Android Project

3. Fill'in the project details with the following values:

* Project name: HelloAndroid
» Application name: Hello, Android

« Package name: com.example.helloandroid (or your own private namespace)

» Create Activity: HelloAndroid
* Min SDK Version: 2

New Android Project x|

4 ‘ I ICk FI n I S h New Android Project
. . .
Creates a new Android Project resource. q 3

Project name: | HelloAndroid |

Contents
O Create new project in workspace
) Create project from existing source
Use default location
Location: |/home/joo/workspace/HelloAndroid Browse..
) Create project from existing sample

Samples: | ContactManager

Properties

Application name: |Hello, Android

Create Activity: |HelloAndroid

|

Package name: |andr0id.hel|o |
|

|

Min SDK Version: |7

@ < Back H Next > | | Cancel ‘ [ Einish
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— Hello World Tutorial(

< Description of each field

Project Name > e e
» the name of the directory that will contain the project files

Application Name
« the name that will appear on the Android device

Package Name

» This is the package namespace that you want all your source code to reside
under

Create Activity
» This is the name for the class stub that will be generated by the plugin
» This will be a subclass of Android's Activity class

Min SDK Version
» This value specifies the minimum API Level required by your application
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— Hello World Tutoria|(6/7)@

% Android Project is now ready 4
= Open the HelloAndroid.java file, then type like this:
[J] *HelloAndroid.java 2 = 5
package android.hello; -

=import android.app.Activity;
import android.os.Bundle;
import android.widget.TextView;

public class HelloAndroid extends Activity {
/** Called when the activity is first created. */
@lverride
public void onCreate(Bundle savedInstanceState) {
super.onCreate(savedInstanceState);

TextView tv = new TextView(this);
tv.setText("Hello, Android!");
setContentView(tv):

H
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— Hello World Tutorial(7/7)(%)
“ Run the Application .

1. Select Run > Run.
2. Select "Android Application”.

5554:my_avd_2.1

Hello, Android ﬂ ﬂ m ”

1o fafals Js [s]s [o o
o fw e {a r [y Ju i fo|p
o Js Jo [ o [u [y Jic[s |28
2z e v Io [y o], o0
P O S P

= The Eclipse ADT will automatically create a new run configuration for
your project and the Android Emulator will automatically launch.

= You will need some patience, while the emulator is booted up
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